Problem installing rbenv in Ubuntu

I am having trouble installing Rbenv in Ubuntu. This is what I am getting. I have been looking everywhere for the past 3 days to no avail…

jayonethesk8@Jubuntu:~$ rbenv install 2.3.1
Downloading ruby-2.3.1.tar.bz2…
-> https://cache.ruby-lang.org/pub/ruby/2.3/ruby-2.3.1.tar.bz2
Installing ruby-2.3.1…
ruby-build: use readline from homebrew

BUILD FAILED (Ubuntu 18.04 using ruby-build 20180424)

Inspect or clean up the working tree at /tmp/ruby-build.20180503135220.17150
Results logged to /tmp/ruby-build.20180503135220.17150.log

Last 10 log lines:
make[5]: Leaving directory ‘/tmp/ruby-build.20180503135220.17150/ruby-2.3.1/ext/fiddle/libffi-3.2.1’
make[4]: Leaving directory ‘/tmp/ruby-build.20180503135220.17150/ruby-2.3.1/ext/fiddle/libffi-3.2.1’
make[3]: Leaving directory ‘/tmp/ruby-build.20180503135220.17150/ruby-2.3.1/ext/fiddle/libffi-3.2.1’
linking shared-object fiddle.so
make[2]: Leaving directory ‘/tmp/ruby-build.20180503135220.17150/ruby-2.3.1/ext/fiddle’
linking shared-object nkf.so
make[2]: Leaving directory ‘/tmp/ruby-build.20180503135220.17150/ruby-2.3.1/ext/nkf’
make[1]: Leaving directory ‘/tmp/ruby-build.20180503135220.17150/ruby-2.3.1’
uncommon.mk:203: recipe for target ‘build-ext’ failed
make: *** [build-ext] Error 2

Hi Justin,

Is this discussion relevant to your problem?