Problem installing dot files on linux

Hi Kevin, I’m having a lot of trouble installing the dot files on Linux. i’m running elementary OS based on ubuntu 16.04 and I got atom to install, but when i got to the dot files “https://github.com/appacademy/dotfiles/blob/master/README.md#using-the-dotfiles-repo” , on install the requirements, I run “~/.dotfiles/bin/install_requirements” I get “install_requirements failed: Unsupported OS” so I go to the manual setup “https://github.com/appacademy/dotfiles/tree/master/requirements” and I run the first command under “Machine setup” “requirements_dir = $( pwd )” and I get “requirements_dir: command not found”. and after experimenting with it, I navigate to the requirments dir and it doesn’t work. after that, I tried with multiple commands on the page, I think I was able to install brew I had to modify the command a bit. My take on it is that I think the commands written on this page are a bit old, because sometimes my terminal suggests alternative commands. anyway, I got stuck again. I wasn’t able to move past Brew. Please help.

Hi Younis,

Let’s setup a Google Hangout to make sure you have an environment setup capable of getting you through the Alpha course. What time works best for you?

I removed elementary and installed Ubuntu, I ran the code, there are a couple of errors in the middle, but I got stuck with the last command.

Use `bundle show [gemname]` to see where a bundled gem is installed.
install_requirements: Gems installed
install_requirements: Installing Git completion...
install_requirements: Press enter to continue.

/home/younis/.dotfiles/bin/install_requirements: line 109: curl: command not found
/home/younis/.dotfiles/bin/install_requirements: line 110: curl: command not found
install_requirements: Git completion installed.
install_requirements: Installing NVM...
install_requirements: Press enter to continue.

Cloning into '/home/younis/.nvm'...
remote: Counting objects: 6294, done.



Installing rspec to /home/younis/.atom/packages ✓
install_requirements: Atom packages installed.
install_requirements: done.
younis@younis-HP-ENVY-Notebook:~$ ~/.dotfiles/bin/install_dotfiles
/home/younis/.dotfiles/bin/install_dotfiles: line 3: rbenv: command not found
/home/younis/.dotfiles/bin/install_dotfiles: line 4: : command not found

today anytime would work. Just email me whenever you’re ready.

younis.hamalawy@gmail.com

would 8 pm (pacific) tonight work for you?

@kevin
I’m having the same issue as Younis. Basically ‘command is not found’ when trying to install_dotfiles. Were you able to find a solution?

Thanks
Brian

Hey Brian,

Younis’ setup was pretty unique because of installation on Ubuntu. We ran into all sorts of strange errors but eventually everything was setup and he is good to go. Are you also working on Ubuntu? Let me know if you are unable to progress through the course and we will schedule a Google Hangout to make sure everything is resolved.

Thanks!

Kevin,
Yes I am on Ubuntu. I still have not installed the dot files…the error
is command not found. That being said…I haven’t noticed any issues and
am able to progress through the course.

I do have a separate question. Is it intentional that I am unable to
access the course material that speaks to the problems in rspec?..for
example I need to understand method blocks for rspec2…yet I can’t access
the section on blocks because I have not finished all the rspec?

Thanks
Brian

Hi Brian,

Glad you are able to progress through. Any additional setup problems can be solved at the beginning of the bootcamp. Currently the task-by-task process is intentional but after a lot of feedback similar to yours we will be removing this. We will also be working on making the curriculum more sequential so those readings come before the exercises.

Thanks again for the feedback, site update is around the corner!