Linux setup - dotfiles

Hey there, I have been successfully able to install the dotfiles requirements, with the exception of sqlite3. But when I try to run the second script, install_dotfiles, I run into an error, rbenv not found. When I scroll back through the logs, I have this error as well:
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

I’m hoping someone has experience with running the scripts on ubuntu and can help me out?

Hmm, looks like either rbenv failed to install or failed to be added to your PATH (this means the rbenv command won’t work). Let’s try reinstalling it (shouldn’t hurt if already installed).

Run the following code (one line at a time) in the console.

# install rbenv
git clone https://github.com/rbenv/rbenv.git ~/.rbenv

# add to PATH
echo 'export PATH="$HOME/.rbenv/bin:$PATH"' >> ~/.bashrc

# make sure rbenv is used with every terminal session
echo 'eval "$(rbenv init -)"' >> ~/.bashrc

# update current terminal session 
source ~/.bashrc

# allow ruby version installation
git clone https://github.com/rbenv/ruby-build.git ~/.rbenv/plugins/ruby-build

# install ruby and use globally
rbenv install 2.3.1
rbenv global 2.3.1
rbenv rehash

Once finished, try re-running the dotfiles. Let us know how it goes.

Good luck!

Thanks for the help, and yes, once I had the .bashrc updated things worked out a lot better. I still get errors when I run the dotfiles_install script, but am also able to do the exercises so far, and no more rubocop errors, so I think I got it. :slight_smile: