App Academy

Issues with GIT

I thought that I was following the instructions on git but I am making a mistake somewhere. When I initialized the directory with git init, and then added the files with git add ., I then committed with git commit -m " ". I then subdirectory by doing mkdir in ubuntu under the images directory (after making a branch git branch drawings). I then moved the required images with mv to the subdirectory. I then committed the changes. When I tried to merge the branches git stated that it had already been done. From there everything just went downhill and I am lost. When I checked the file structure in the terminal it is out of order. I had to close the terminal so I lost a lot of what I was doing.

I am not sure if the damage that I have done would require me to delete the project and just download it again and start over.




notice on the last screenshot when I tried to merge the git merge together inside the master branch it says “Already up to date.” I am lost. After that I just started making changes to stuff (not knowing fully where I was going with it) and I think I may have made changes where I should not have.

Good morning!
It sounds like you made the right call in recognizing that something was off and coming to the forum.

While I’m not sure of the root cause, I have a suspicion.

If you were in a directory other than the root directory when you used your staging and commit commands, it is likely that you only staged and committed some of the changes, but not all of them. For example, if you stage and commit from the images directory, you won’t actually be committing any changes to the html file because it is outside that directory.

If it sounds like this may be the case, I would recommend starting a new assessment, especially since you wrote that you may have started changing things without being sure of what was going on. In the new assessment, I would cd back to the root directory before staging and committing changes, and make sure you are in the root directory when you checkout between branches. This will help ensure that you are committing all of the changes, not just changes within a particular subdirectory.

Like I said, this is my best guess at this point based on what you described and posted. Let me know what this makes you think, and we can continue troubleshooting if it seems like something else might be going on.

Jesse

Thanks for the reply. Much appreciation.

Should I remove the git-repo-management file by going to the terminal and entering the command rm git-repo-management? Or would I just open it up in the downloads menu and just delete the entire folder?

I cannot delete the git-repo-management folder; the computer will not allow me. I have tried to from the terminal and I receive this message: “cannot remove git-repo-management: Is a directory.” I then tried to delete it in the downloads section and it states: “You’ll need to provide administrator permission to delete this folder.” It still will not let me delete it even after I click continue and the skip option. I googled the message that it gave me and it is stating windows will not let you delete the folder/file because of certain security reasons. It then gave me several ways-like taking ownership of the file- to delete it and it still isn’t working. I do not know how to delete this folder and I have never seen anything like this.

I am not sure if this will work, but try searching for Ububtu on the search bar, right click, and run as administrator