Installing Dotfiles Error / Ruby Project Bundle Command Not Found

Hi Kevin, I’m also having issues installing the dotfiles and getting the bundle to install for A Ruby Project. Please let me know if you’ll be available to walk me through it over Google Hangouts, thanks!

I am as well. Please let me know if you find a solution.

Hi, I had a same error and struggled for hours to install Dotfiles correctly!
However, this post explains a lot and I was able to solve it with this help.

  • In my case, I followed the environmental setup instruction for Mac, but I failed because I didn’t have .bashrc and .bash_profile in my root directory.
  • So I had to run a command of copying both into .bashrc file and .bash_profile file respectively, and after that, all installation of the requirements and the configuration files went well.
  • A command was 1) cp ~/.dotfiles/dot/bashrc ~/.bashrc 2) cp ~/.dotfiles/dot/bash_profile ~/.bash_profile in terminal.

Hope you guys to solve or connect with Kevin soon!

Hi Hiro, thanks for offering your help. I tried the commands you posted, but unfortunately it’s still not working out for me. I also noticed that I get the error below when trying to install the requirements. Not sure if it’s a related issue or a separate problem.

ERROR: While executing gem … (Gem::FilePermissionError)
You don’t have write permissions for the /Library/Ruby/Gems/2.0.0 directory.
/Users/jc/.dotfiles/bin/install_requirements: line 101: bundle: command not found

Hi Josh,
I’d go back to the step of “Changing ownership of /usr/local” (sudo command) and give it another try from there.
(Later, I was prompted to enter the pass in terminal while downloading the requirements.)
Also, I’d open .bashrc file to check if the PATH is set right. Otherwise, I’d wait for Kevin’s help…