HTML/CSS Assessment Question on Form

Learning Challenge

HTML Pet Form

Question

I wanted to know if nothing is showing because I haven’t done the css portion? I thought at least a basic version of the form would show up.

What I’ve tried

I’ve typed out the whole code out in visual studio code and saved it but when I run explorer.exe . and click the chrome icon, a tab opens up but nothing is displayed.

Screenshots




Theoretically, it should definitely be showing up in the browser.

Things I would check:

  1. Take a look in your site.css and see if there is anything in there that is hiding something?
  2. It also looks like you’re using WSL. The file you’re editing may be in the “Linux File System” and when you’re opening it in Windows using Chrome, it might be problematic. You may want to try doing the assessment from your Windows “Documents” folder. Copying over your index.html and site.css into an html_css_assessment folder in the “Documents” folder on Windows. See if that has a better outcome for you.

Thank you @bryanray!!! That completely did the trick. I knew something was wrong when it opened up from Ubuntu and the chrome icon said there was 0 KB of data in the file.

Why when I copied and pasted it from directory in that was in PC > Downloads > html_css_assessment did it not have any data in the file but when I copy and pasted it, it all of a sudden had all the data and even the images that were part of the original zip file? I’m just curious.

One other question: In the terminal how do I change directory to PC > Downloads? Before it was in the original file directory Visual Studio Code where we have been making all our directories and files. Why won’t it work from there or even show any data in the files?

Thanks again!!!

This is just a major confusion point from the Windows and Windows Subsystem for Linux (WSL) integration. The file you were looking at was (probably), technically, living on a Linux file system. For all intents and purposes, it was just a file on a Linux operating system.

You were attempting to open that file in Chrome and this is just not how the WSL system is meant to be naturally used. More than likely the permissions on the file were just not adequate enough for Chrome to read it.

It’s super confusing and, to be honest, I do not understand the intricate details myself. I’ve just always tried to avoid it altogether.

My recommendation for you would be to simply use the PowerShell Terminal to do your assessments. Opening up PowerShell you should be able to simply go to cd ~/Downloads or cd ~/Documents/html_css_assessment

When you’re using the Ubuntu Terminal you just have to deal with this added overhead that “I’m on the Linux files system.” If you stick with Windows PowerShell or Windows Terminal you’re just “always in Windows” and can avoid a lot of unnecessary confusion.

Hopefully that wasn’t too much to digest and I haven’t added any extra confusion. Let me know if there is anything else.

1 Like

Not at all @bryanray!!! You actually cleared up all the confusion about it. Thank you so much for taking the time. I really do appreciate it because I’m sure you’re busy.

1 Like