Git commit and push functions not working

Hi there, I’m having trouble successful uploading the first project. When I type:

$ git commit -m “first proj”

I get this:


*** Please tell me who you are.

Run

git config --global user.email "you@example.com"
git config --global user.name “Your Name”

to set your account’s default identity.
Omit --global to set the identity only in this repository.

fatal: unable to auto-detect email address (got ‘adrian@adrian-Inspiron-N5110.(none)’)


Following the instructions doesn’t make it stop happening.

When I push it, I just enter my password and it says “Everything is up to date.” but, bitbucket doesn’t get updated.

For now, I just copied and pasted my project onto bitbucket and committed it from the bitbucket edit window. After that, I got the “project successfully commited” window on the alpha course.

FYI: I’m using Ubuntu 16.04 for now. Any suggestions? (Please also comment on formatting norms for postings, if necessary).

1 Like

I had this issue as well. I ran the two config commands provided in the error using my AAonline email and a username, the commit worked after that.

As it turns out, this problem seems to have spontaneously fixed itself. I tried it again today and got it to work. I had to run a “git config --global user.email "myemail.@gmail.com” and then it all worked.