Git Assessment Don't know what went wrong

This is what I got for all four “questions”

fatal: ambiguous argument ‘student/drawings’: unknown revision or path not in the working tree.Use ‘–’ to separate paths from revisions, like this:‘git […] – […]’

Apparently nothing worked. Everything looked fine on my computer. There are pictures in the assessment as to what the html should look like along the way and my work always matched.
The only thing that was different was that the assessment didn’t download into my “downloads” file. The instructions were to always pull the files from there, but that’s not where mine were so I would navigate to a different file. Other than that, there wasn’t any difference. I’m thinking I didn’t get everything in the zipfile that I was supposed to.
The website shows the four pictures from the html. The html matches the picture on the website. The bar on the left side matched the outlines in the website example, except for the .gitignore.gitignore file.

Hi Melissa, and welcome to the community!

I was able to go in and manually pull up your submission, and I also ran into fatal errors similar to what you received on your diff. It looks like our tests were not able to read the files in your repository:

fatal: '../.././student/git-repo-management/' does not appear to be a git repository
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.
drawings
fatal: ambiguous argument 'student/drawings': unknown revision or path not in the working tree.
Use '--' to separate paths from revisions, like this:
'git <command> [<revision>...] -- [<file>...]'
master
fatal: ambiguous argument 'student/master': unknown revision or path not in the working tree.
Use '--' to separate paths from revisions, like this:
'git <command> [<revision>...] -- [<file>...]'
pictures
fatal: ambiguous argument 'student/pictures': unknown revision or path not in the working tree.
Use '--' to separate paths from revisions, like this:
'git <command> [<revision>...] -- [<file>...]'
together
fatal: ambiguous argument 'student/together': unknown revision or path not in the working tree.
Use '--' to separate paths from revisions, like this:
'git <command> [<revision>...] -- [<file>...]'

Overall, I think the .gitignore file is a minor problem, but not the root problem.

  • Did you follow the instructions for setting up the .gitignore file, or use some kind of npm package for that?

I would make sure to manually edit the .gitignore filename so that it matches the instructions for the assessment, across all four branches.

Also, check the file permissions for your repo.

I’ll try to loop in some people who are more familiar with Ubuntu who might be able to help. I have a feeling this may have to do with read/write permissions or scope, and possibly related to working from a different folder than the downloads folder.

Jesse

Hi Melissa,

Adding on to the previous reply…

The problem may not be related to your files themselves, but how you zipped them. It seems that some of the files did not make it into your zip folder. For example, there should be a .git file, but it was not in your submission.

First, go ahead and fix the .gitignore file (in the previous reply). Then follow the instructions from the assessment prompt to zip your submission. Before you click “send to”, make sure you have NOT selected only visible folders, because your submission needs to include the hidden folders as well.

Give this a try, and let us know what happens. Happy to continue troubleshooting if this doesn’t take care of it.

Jesse

The instructions said “Create a file named “.gitignore” in the git-repo-management directory. Using Visual Studio Code, type .DS_Store in the “.gitignore” file. Save it.”

I misunderstood the directions. I opened a file in Visual Studio Code and named it gitignore.gitignore

Today I used ubuntu using “touch gitignore.gitignore” and created a file.
Then I committed it to the branch master

Now there is a proper git file in my git-repo-management folder.

The zip file still seemed to be missing the html for the site. I’m going to delete it all and start over from downloading it into the download file so I know where it is and everything should end up there. The final zip should work.

1 Like

Sounds good. Also, make sure your gitignore file is named .gitignore, not gitignore.gitignore. There should be nothing before the dot.

Can you please put down an example of ‘git […] – […]’?

I received the same messages and looked through my history log.2021-02-22 (2)