Error message when installing Pry gem

Receiving this message while installing pry gem…

ERROR: While executing gem … (Gem::FilePermissionError)
You don’t have write permissions for the /Library/Ruby/Gems/2.6.0 directory.

Anybody else run into this?-- stackoverflow cannot agree on a solution that makes sense for my understanding of paths and user access. Scared to troubleshoot without insight!

I figured it out…turned out to be a path issue.

1 Like