Error loading .rb files for control and ennumerables exercises

Howdy -

I’m having a problem when I try to test my work in the control flow and enumerables exercises.

After working on my code in atom, I run bundle exec rspec --color a few times. Then, after another round of edits, I get this error when I run the test:

And at the bottom, instead of getting the summary of examples and failures, the message

“0 examples, 0 failures, 1 error occured outside of examples”

I haven’t found anyone else in the a/A forums who has had this problem. Quitting terminal and running bundle install again hasn’t worked, nor has a good ol’ restart.

Any idea what I’m doing wrong? I didn’t have this problem with the data structures or methods exercises.

Here is a screen shot of the “failure” message at the end:

So if you read the error most of the information is given there.

SyntaxError: /Users/... /enumerables1.rb:12: void value expression /Users/... /enumerables1.rb:92: syntax error, unexpected end-of-input, expecting keyword_end

There are 2 syntax errors in enumerable1.rb
Check line 12 and 92. Not sure about line 12 but it seems that you’re missing an “end” at line 92
Once you fix the syntax errors the spec file should run correctly

Ha of course! [Slaps self on forehead]. Thanks Harsh. TIL that if there are certain errors in your code, it won’t even load the tests.