App Academy

Drawings Subdirectory

working on subdirectories and I don’t understand why I’m not able to see files that I have moved into the drawings subdirectory. Thanks in advance!

Also, is the pop-up in the site.html ok? not sure what this means.

Hi Natalie,
In terms of the pop-up, have you been making a lot of changes without staging / committing?

If you click on the blue circle on the left sidebar, what do you see? (A screenshot would be great).

My suspicion is that you have made a lot of changes but perhaps have not staged or committed them, and that might be what is going on with the error, and why things are not showing up as expected.

moving the image is the only change I made so far. And what’s weird is it shows it’s gone from the images folder but not in the drawings. So I’m not even sure where the .jpg went.

OK, the blue clock icon means that VSCode is processing some changes, but I’m guessing that it has been stuck with that icon for awhile. When it finishes processing, you should be able to see changes appear in the sidebar (your most recent screenshot).

I’m not sure about the cause, but it does look like VSCode is “stuck” in this processing, which is causing things to not show up where they should.

A few things to try:

  • Try closing VSCode and re-opening. Any change?
  • Make some changes in the site.html and save them. Does the clock remain?
  • If you still have the old git project, I would delete it or at least rename it, to make sure you’re not accidentally applying changes from the terminal to the outdated project files.

I exited out and then went back in and it showed this. However, it didn’t show in the drawings folder. Sorry, just a little confused. Do I need to git commit before it will show up in the folder?

I don’t have the old git folder, I deleted that before I started. However, I have been doing this quite a lot to make sure I get it right. Thought that may be an issue.

Made changes to site.html and the number just went to 2. Closed it, opened it again and it still remained.

Update!!

I deleted all git files, shut down my computer and then started over…I created the new branch, the new subdirectory and saved everything. It appears to still not show me any files in the “drawings subdirectory” but there are no changes on the site.html that need to be saved.

OK, I think you’re in good shape because you’ve been able to get rid of that error and you’ve been able to see changes showing up (the blue numbers). I would recommend proceeding with the directions at this point. Make sure you do all of the staging and committing when you get to those parts.

When you’re finished and have committed the last change, close out of VSCode and re-open to do a final check of each branch. Make sure there are no changes remaining (no blue numbers), and make sure everything matches up with the the directions.

Jesse

For some reason the .jpg still isn’t showing up under the drawings file. What would be the reason for this? (see screenshot above)

Oh - I see exactly what is going on now!

If you look at the bottom left corner of the screen, you will see “drawings” under the settings icon. But the branch name has a typo. So when you’ve been making modifications, you’ve probably used the correct spelling so the changes aren’t registering on the misspelled branch.

AH it worked! thanks for the help. I have one more question. How do I get the tree to pop up in my code for me to double check? When I type “tree” it doesn’t seem to work for me.

Best,
Natalie

1 Like

Do you mean in VSCode?
On a mac you can type command-b, or click on the top icon on the left sidebar.

No, in Terminal. like this:

Oh yes. tree works, but only if you have already installed a package that enables it.

If it’s not already installed, check out this link for details - .

To install on mac you can use brew install tree, and then the tree command will work for you.

Awesome! Thanks so much