App Academy

Couldn't install sqlite3 gem, but found a temporary solution

I was having issues with gem install sqlite3.
The error message on the terminal was:

ERROR: Could not find a valid gem 'sqlite3' (>= 0), here is why: Unable to download data from https://rubygems.org/ - timed out .........

After digging into some forums, it seems that rubygems.org is having issues connecting through IPv6.
Source: debian jessie - gem cannot access rubygems.org - Stack Overflow

The temporary solution is to configure IPv6 to “Link-local only” for downloading the gem and change it back once the gem is installed. (See the second solution in the above link.)

Hope this helps.